ryanh827
i have a 2005 duramax and it keeps going into limp mode between 3 and 5th gear only way to get it to go through all the gears is to go slow as possible and then its 50/50 if you half throttle wont get past 3 and limp mode kicks on got it scanned says stuck shift solenoid e so i got the solenoid changed by a shop went into limp mode instantly pulled up the same code for the part he just changed took it 3 places on says needs a computer one says needs a tranny and one says its just an electrical issue not sure what to do
Quote 0 0
Rbrayfield82
Check all grounds. Especially under passenger side frame rail. Had that same issue several years back. Also check fuel filter, yes fuel filter, and tranny fluid and tranny filter change if you haven't already.
Quote 0 0
Rbrayfield82
Just seen how old this is. Sorry. What was the issue?
Quote 0 0
Andrew Knolle
ryanh827 wrote:
i have a 2005 duramax and it keeps going into limp mode between 3 and 5th gear only way to get it to go through all the gears is to go slow as possible and then its 50/50 if you half throttle wont get past 3 and limp mode kicks on got it scanned says stuck shift solenoid e so i got the solenoid changed by a shop went into limp mode instantly pulled up the same code for the part he just changed took it 3 places on says needs a computer one says needs a tranny and one says its just an electrical issue not sure what to do
Quote 0 0
Andrew Knolle
Needs a new wiring harness,the wires have rub through and touching the frame
Quote 0 0
http://www.bigshocks.com/" target="_blank">