Trucks Gone Wild Classifieds, Event Information and Mud News
Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment  
ryanh827

True Bogger
Registered:
Posts: 200
Reply with quote  #1 
99 cummins 47re 2wd has been fine but today if I got it to around 2000 rmps the truck would start shaking so I drove slow stop at a light and the truck would barely take off and wouldn't shit would only do about 25 half throttle next light nothing wouldn't mover in drive or reverse figured a torque converter went out after about 45 minutes started it up it drove fine for about 10 minutes then started slipping then wouldn't move again I read it could be a governor pressure solenoid or sensor please help
0
shiftkit@specialtytrans.com

Avatar / Picture

Forum Newbie
Registered:
Posts: 1
Reply with quote  #2 
 No, the gov psi sol or sensor will cause it to pull in 3rd gear & will also have reverse. The pan is full of debris & is clogging the filter up is why it stops until U shut it off for a little time & then start off again. Sorry but it's time for a new trans.
    Jeff    37 yrs Trans Building
0
ryanh827

True Bogger
Registered:
Posts: 200
Reply with quote  #3 
Quote:
Originally Posted by shiftkit@specialtytrans.com
 No, the gov psi sol or sensor will cause it to pull in 3rd gear & will also have reverse. The pan is full of debris & is clogging the filter up is why it stops until U shut it off for a little time & then start off again. Sorry but it's time for a new trans.
    Jeff    37 yrs Trans Building

I just didn't want to believe that haha the tranny was fully built by aamco it was 4 years ago yah but I have $4000 in receipts from all the parts I figured maybe it was worth saving so by debris you mean pieces of metal ?
0
SixinaRowMakesItGo

Avatar / Picture

True Bogger
Registered:
Posts: 457
Reply with quote  #4 
Pieces of metal maybe. Your clogging up on clutch material. More Then likely its the lockup clutches going out. Could just need a good cleaning and a new torque converter.
0
ryanh827

True Bogger
Registered:
Posts: 200
Reply with quote  #5 
Quote:
Originally Posted by SixinaRowMakesItGo
Pieces of metal maybe. Your clogging up on clutch material. More Then likely its the lockup clutches going out. Could just need a good cleaning and a new torque converter.
it ended up just being an extremely clogged filter but I drove it home half throttle doing like 15 and fried the clutches in the process lol the guy said it would of been fine but I overheated it so bad the clutches turned colors
0
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.